SV650.org - SV650 & Gladius 650 Forum



SV Talk, Tuning & Tweaking Discussion and chat on all topics and technical stuff related to the SV650 and SV1000
Need Help: Try Searching before posting

Reply
 
Thread Tools
Old 01-11-18, 10:19 PM   #1
Adam Ef
Member
 
Adam Ef's Avatar
 
Join Date: Dec 2015
Location: Bristol
Posts: 314
Default Right indicators not working - Wiring advice?

Riding today and just about home when I noticed my indicators weren't working to turn right. Both front and rear. Left hand is all ok. Right hand work too when used as hazards so bulbs are fine and power is reaching them. I've looked under the tank and in trying to pull wires and connectors to somewhere I can see them have got the right hand ones working on their own intermittently. So it's either a dodgy wire, loose connection or a connector block that needs cleaning.


Just after a quick bit of advice if anyone knows which of the connector blocks I need to pull... photo below. Before I try and pull them all into a position I can work on. They're quite tightly tucked in there.


Adam Ef is offline   Reply With Quote
Old 02-11-18, 08:17 AM   #2
Seeker
Member
 
Join Date: Jun 2016
Location: NE Lincs
Posts: 200
Default Re: Right indicators not working - Wiring advice?

I had a similar problem on a Triumph and it was the handlebar switch. Contact cleaner didn't provide a long term fix, I had to dismantle the switch and clean the contacts. On reassembly I used dielectric grease and had no more problems.
Seeker is offline   Reply With Quote
Old 02-11-18, 09:08 AM   #3
SV650rules
Member
 
Join Date: Nov 2016
Location: Shropshire UK
Posts: 734
Default Re: Right indicators not working - Wiring advice?

Yeah sounds like handlebar switch contact corroded.
__________________
SV650 AL7

Courage is resistance to fear, mastery of fear, not absence of fear - Mark Twain
SV650rules is offline   Reply With Quote
Old 02-11-18, 10:51 AM   #4
Bibio
Member
Mega Poster
 
Bibio's Avatar
 
Join Date: Jul 2008
Location: Dreich Fife (its grey and miserable)
Posts: 11,002
Default Re: Right indicators not working - Wiring advice?

i'll go for a corroded indicator connector in the inside of the headlight cowling. failing that then the white block connector also in the headlight cowling. its a common problem with the white connector.
Bibio is offline   Reply With Quote
Old 02-11-18, 12:19 PM   #5
Adam Ef
Member
 
Adam Ef's Avatar
 
Join Date: Dec 2015
Location: Bristol
Posts: 314
Default Re: Right indicators not working - Wiring advice?

Cheers all. The indicators work when these connectors are nudged, but no change when the wiring around the switch is moved. That and the fact it's both front and rear right hand indicators leads me to suspect something around these connector blocks.
Adam Ef is offline   Reply With Quote
Old 21-11-18, 07:51 PM   #6
Toooldtodie
Member
 
Toooldtodie's Avatar
 
Join Date: Jun 2012
Location: Chelmsford
Posts: 357
Default Re: Right indicators not working - Wiring advice?

Quote:
Originally Posted by Bibio View Post
i'll go for a corroded indicator connector in the inside of the headlight cowling. failing that then the white block connector also in the headlight cowling. its a common problem with the white connector.

Same. Bypassed with new connectors and wires, left one's been fine. Bit like the headlamps and their connector block.
__________________
You may think I'm a total idiot, but actually there are important bits missing.
05 SV650s now with proper suspension, hurrah!
Toooldtodie is offline   Reply With Quote
Old 21-11-18, 09:52 PM   #7
Adam Ef
Member
 
Adam Ef's Avatar
 
Join Date: Dec 2015
Location: Bristol
Posts: 314
Default Re: Right indicators not working - Wiring advice?

I'm not 100% convinced mine is fixed, but I did undo the block in the above photo and sprayed it with contact cleaner. It's been fine since. Really need to strip it all down and inspect it properly though.
Adam Ef is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wiring LED indicators? LewSpeight Bikes - Talk & Issues 3 08-01-13 06:29 PM
Help wiring HID's - High/Low solenoid not working right DarrenSV650S Bikes - Talk & Issues 1 30-06-11 10:06 PM
Rear Indicators (wiring)? W4tto SV Talk, Tuning & Tweaking 5 25-06-11 01:33 PM
Rear Indicators - to take the wiring from neilhatch Stuff Wanted 4 17-10-08 02:21 PM
Wiring in aftermarket indicators? steve mac SV Talk, Tuning & Tweaking 5 08-02-05 05:41 PM


All times are GMT. The time now is 03:31 PM.


Powered by vBulletin® - Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.