SV650.org - SV650 & Gladius 650 Forum



SV Talk, Tuning & Tweaking Discussion and chat on all topics and technical stuff related to the SV650 and SV1000
Need Help: Try Searching before posting

Reply
 
Thread Tools
Old 26-05-18, 09:02 PM   #11
netsurfer
Junior Member
 
Join Date: Apr 2018
Location: N.Ireland
Posts: 22
Default Re: K1 starts but cuts out after a second or two.

You will need 2x Choke plunger O-rings Suzuki p/n 1327818E20 and bowl gaskets (rubber o-ring type) which will probably be in the carb repair kit, if not these are Suzuki p/n 1325833E00

Not got my service kits yet, but seems like there are loads online.
netsurfer is offline   Reply With Quote
Old 26-05-18, 09:04 PM   #12
daktulos
Member
 
daktulos's Avatar
 
Join Date: May 2016
Location: St Albans
Posts: 148
Default Re: K1 starts but cuts out after a second or two.

Have you checked the vacuum to the petcock or fuel pump? (I'm not familiar with the K1, but it sounds like it's running from fuel in the float bowl and then getting no more, the hour could be it dripping through.
daktulos is offline   Reply With Quote
Old 26-05-18, 09:42 PM   #13
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Hi,
I've started it with and without choke - no real difference.
It does fast idle briefly before stopping.
I can restart it after an hour or so.
I have not tried to restart it with the petrol filler cap open.

Just googled some carb rebuild kits - thanks.

Quote:
Originally Posted by Seeker View Post
Are you using choke?
How does it respond on choke - does it fast idle briefly before stopping.
Once it's started does it respond to throttle?
How long do you have to wait before it will restart?
Have you tried starting it with the petrol filler cap open?

Carb rebuild kits are available for the curvy. Be careful with the carb screws they tend to be quite soft and are JIS headed not Philips although they look similar. Once you get the float bowls off you'll get a better idea if it's a dirt issue.
ejohnh is offline   Reply With Quote
Old 26-05-18, 09:44 PM   #14
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Thanks,

Just googled some sources,

Quote:
Originally Posted by netsurfer View Post
You will need 2x Choke plunger O-rings Suzuki p/n 1327818E20 and bowl gaskets (rubber o-ring type) which will probably be in the carb repair kit, if not these are Suzuki p/n 1325833E00

Not got my service kits yet, but seems like there are loads online.
ejohnh is offline   Reply With Quote
Old 26-05-18, 09:48 PM   #15
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Vacuum to tank tap and to fuel pump is okay. I had petrol pumping into a bottle while turning over the engine.
It seems like a float thing is sticking but I wouldn't thought that both would stick at the same time. It's been idle for several years so that could well be the case.

Thanks.

Quote:
Originally Posted by daktulos View Post
Have you checked the vacuum to the petcock or fuel pump? (I'm not familiar with the K1, but it sounds like it's running from fuel in the float bowl and then getting no more, the hour could be it dripping through.
ejohnh is offline   Reply With Quote
Old 27-05-18, 12:13 PM   #16
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Yes, I'll do all of that. A mate of mine has what he calls a sonic cleaner. How do they work?
ejohnh is offline   Reply With Quote
Old 27-05-18, 12:20 PM   #17
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

First I'll try the Mechanic in a bottle. If that fails I'll whip the carbs off for a close look.
ejohnh is offline   Reply With Quote
Old 27-05-18, 12:29 PM   #18
Bibio
Member
Mega Poster
 
Bibio's Avatar
 
Join Date: Jul 2008
Location: Dreich Fife (its grey and miserable)
Posts: 10,920
Default Re: K1 starts but cuts out after a second or two.

take a long screwdriver and tap the float bowls with the handle end. this sometimes frees up the float valves.
Bibio is offline   Reply With Quote
Old 04-06-18, 10:48 PM   #19
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Latest:

I tried Mechanic In a Bottle over the course of 4 days, trying to start the engine every couple of hours or so. I was hoping that with the mixture travelling through the carbs, the gunk or whatever would dissolve. Unfortunately that didn't happen so I'll send of for a couple of carb rebuild kits etc,, Thanks for all your advice guys, I'll let you know how I get on.
ejohnh is offline   Reply With Quote
Old 05-06-18, 02:48 PM   #20
ejohnh
Member
 
Join Date: Oct 2006
Location: Porthcawl Wales UK
Posts: 967
Default Re: K1 starts but cuts out after a second or two.

Quote:
Originally Posted by Seeker View Post
I haven't watched his videos but this guy either gives a comprehensive sv carb cleaning procedure or likes to talk:

https://www.youtube.com/watch?v=do7B2T-kNkU (there are 6 videos)
Just been watching the vids. What a great idea. Thanks..
ejohnh is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pointy K3 Cuts out Rich Clarke SV Talk, Tuning & Tweaking 3 21-10-14 08:46 PM
Engine cuts out. Bike_Nutter Bikes - Talk & Issues 2 18-09-14 05:26 PM
Legal Aid cuts Ed Idle Banter 20 30-06-11 10:14 AM
Budget cuts and the like... Stingo Idle Banter 5 29-09-10 10:28 AM
Salary cuts keithd Idle Banter 23 18-03-09 03:58 PM


All times are GMT. The time now is 04:22 AM.


Powered by vBulletin® - Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.