SV650.org - SV650 & Gladius 650 Forum



SV Talk, Tuning & Tweaking Discussion and chat on all topics and technical stuff related to the SV650 and SV1000
Need Help: Try Searching before posting

Reply
 
Thread Tools
Old 22-01-22, 12:53 PM   #11
Seeker
Member
 
Seeker's Avatar
 
Join Date: Jun 2016
Location: NE Lincs
Posts: 861
Default Re: battery

Looks like my battery is throwing in the towel, too. Almost 6 years, 32,000 miles, permanently connected to Oxford 3X optimiser over winter.

Went for a ride 3 days ago and noticed that optimiser's "maintaining" was flashing whereas it should be on solid. Bike started ok, maybe turned over a bit slower but no problems during 30 mile run. On return, the maintaining light flashed for an hour then went solid (it would normally go through this stage in a couple of minutes) and optimiser declared battery was "strong".
Still ok yesterday but today flashing again (we had a colder night).
I've just ordered a new battery.
__________________
2016 SV650AL7
2020 Z900RS
Seeker is offline   Reply With Quote
Old 22-01-22, 07:00 PM   #12
svenrico
Member
 
svenrico's Avatar
 
Join Date: Sep 2020
Location: North Yorkshire
Posts: 301
Default Re: battery

Quote:
Originally Posted by Seeker View Post
Looks like my battery is throwing in the towel, too. Almost 6 years, 32,000 miles, permanently connected to Oxford 3X optimiser over winter.

Went for a ride 3 days ago and noticed that optimiser's "maintaining" was flashing whereas it should be on solid. Bike started ok, maybe turned over a bit slower but no problems during 30 mile run. On return, the maintaining light flashed for an hour then went solid (it would normally go through this stage in a couple of minutes) and optimiser declared battery was "strong".
Still ok yesterday but today flashing again (we had a colder night).
I've just ordered a new battery.
My battery seems ok now ,but 6 years and 32,000 miles is a decent life for your battery. I wouldn't complain about fitting a new battery after that amount of
use .
svenrico is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can a loose battery terminal prevent the battery from charging while being able to crank the engine? maxinc Bikes - Talk & Issues 5 22-07-11 02:59 PM
dead battery - possible reg/rec + battery? collis SV Talk, Tuning & Tweaking 8 20-09-10 02:47 PM
Optimate battery charger drains the battery flymo Bikes - Talk & Issues 10 10-06-09 10:41 AM
Battery/Starting problem - new battery hasnt fixed it! Aaron SV Talk, Tuning & Tweaking 13 24-01-05 05:21 PM


All times are GMT. The time now is 08:32 AM.


Powered by vBulletin® - Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.