SV650.org - SV650 & Gladius 650 Forum



SV Talk, Tuning & Tweaking Discussion and chat on all topics and technical stuff related to the SV650 and SV1000
Need Help: Try Searching before posting

Reply
 
Thread Tools
Old 13-05-11, 02:08 PM   #1
muzikill
Member
Mega Poster
 
muzikill's Avatar
 
Join Date: Jul 2005
Location: Dunfermline
Posts: 1,712
Default New fuel pump. problem found

Well after all my checking why my bike wasnt starting after my engine rebuild i have a definite fuel pump on the blink now, all the safety cut outs work fine, no c23 error. The relay comes on and i checked the white triangular connector that connects to the fuel pump lead. When the engine is turned on you get 11v for approx 3 secs which would make the pump turn on and make it prime. There is no dropped neutral at the connector it checks out with a continuity test back to the battery. The other wire is for the fuel level.
It's a real pity that no manuals show you how to test this connector. The only way i worked out what was what at the connector was to read the wiring diagram in the haynes manual to work out which colour of cable was the 11v feed which comes from the fuel relay when the it is turned on. Another thing which is good is that the relay is switched on and off after 3 secs which proves it does the priming sequence and the ecm is working.

Tried giving it a knock with a hammer and re-connected but it looks like it's goosed. What i might do is take it out to check that the fly lead coming out of the tank to the connector hasnt got a short or loose connection.

Do i have to take the fuel out to replace it?
Do i need to replace any o-ings?
__________________
Learn to maintain your bike, take it apart, rebuild the engine & more (using better bolts ), drop it & fix it again!
K3 Job c.v: Engine:remove/split/rebuild/refit. Replace:Gearbox,Fuel pump,Gaskets. Piston clean,rings. Overhaul:Throttle body,Injectors,Brakes,Forks. Remove/refit:Exhaust,Radiator,Oil cooler,Throttle,Air filter,Tank. Replace: Oil,Coolant,grease,brake hoses & bleed.

Last edited by muzikill; 13-05-11 at 02:51 PM.
muzikill is offline   Reply With Quote
Old 14-05-11, 09:43 AM   #2
muzikill
Member
Mega Poster
 
muzikill's Avatar
 
Join Date: Jul 2005
Location: Dunfermline
Posts: 1,712
Default Re: New fuel pump. problem found

Ok, i worked it all out myself 3 quid bit of tubing from b&q and syphoned the fuel out (best not to tip it out!) and it wasnt really that hard to do.
The tank still had a bit of fuel wallowing around in it so i removed the fuel pump (doddle) and used the tube to sook out the rest bit by bit.

Here's how it looks...



When good fuel goes bad!, see that gold looking stuff at the bottom of the black plastic fuel well? That's what it looks like when they go on about fuel going off and going like nail polish causing the fuel pump to fail. It'll be like that inside the sealed unit.
I took out the fuel pump itself and connected it to the sv battery (away from the bike! in case of fumes/spilt fuel) to check it out in case it was a break in the fly lead but i got no motor running. It's shorted/gunked/siezed.

Knackered fuel pump, replacement ordered (k3 white plug version)

It amazes me that this thing with its 'bare' connectors is surrounded by fuel when it's in the tank & works without it igniting!

p.s the fuel gauze in the well wasnt the cleanest either with rust and it was off coloured.
__________________
Learn to maintain your bike, take it apart, rebuild the engine & more (using better bolts ), drop it & fix it again!
K3 Job c.v: Engine:remove/split/rebuild/refit. Replace:Gearbox,Fuel pump,Gaskets. Piston clean,rings. Overhaul:Throttle body,Injectors,Brakes,Forks. Remove/refit:Exhaust,Radiator,Oil cooler,Throttle,Air filter,Tank. Replace: Oil,Coolant,grease,brake hoses & bleed.

Last edited by muzikill; 14-05-11 at 09:53 AM.
muzikill is offline   Reply With Quote
Old 19-05-11, 09:32 PM   #3
muzikill
Member
Mega Poster
 
muzikill's Avatar
 
Join Date: Jul 2005
Location: Dunfermline
Posts: 1,712
Default Re: New fuel pump. problem found

Ok starting issues still occuring. fuel pump was faulty. new one does the priming sound.

Things to check......

Does it send fuel down the hose to the throttle bodies?
Are the throttle bodies clogged? (can they be cleaned?)
Do the spark plugs 'blue' spark?
Is the immobiliser/alarm fookt?
Is the ECM fookt (i hope not)

The bike makes all the right sounds, when you press the starter motor it 'turns' over ..... it's just not kicking in!
ps when the bike turns over and i turn the throttle slightly the engine turns over quicker when trying to start, not sure what that proves!
__________________
Learn to maintain your bike, take it apart, rebuild the engine & more (using better bolts ), drop it & fix it again!
K3 Job c.v: Engine:remove/split/rebuild/refit. Replace:Gearbox,Fuel pump,Gaskets. Piston clean,rings. Overhaul:Throttle body,Injectors,Brakes,Forks. Remove/refit:Exhaust,Radiator,Oil cooler,Throttle,Air filter,Tank. Replace: Oil,Coolant,grease,brake hoses & bleed.

Last edited by muzikill; 20-05-11 at 07:20 AM.
muzikill is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
k3 fuel pump assembly widget Stuff Wanted 0 13-05-10 12:23 PM
Fuel pump problem, maybe. mudgutsdunn SV Talk, Tuning & Tweaking 5 11-03-10 11:54 PM
Fuel Pump Problem hindle8907 Bikes - Talk & Issues 2 29-11-09 01:34 PM
Fuel pump cornishrider SV Talk, Tuning & Tweaking 6 02-03-08 07:25 PM
K5> fuel pump phil24_7 Stuff Wanted 11 29-10-07 05:18 AM


All times are GMT. The time now is 12:44 PM.


Powered by vBulletin® - Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.