SV650.org - SV650 & Gladius 650 Forum



Bikes - Talk & Issues Newsworthy and topical general biking and bike related issues. No crapola!
Need Help: Try Searching before posting

Reply
 
Thread Tools
Old 07-08-11, 09:55 PM   #1
DJ123
Member
Mega Poster
 
DJ123's Avatar
 
Join Date: Jul 2011
Location: Somewhere over there
Posts: 3,245
Default Starting problem-fuel pump not purging

I currently have a problem with my SV650S.
As we all know, when you turn the ignition on, the fuel pump primes up the injection system.
Currently mine is not doing so. I have checked everything that could affect this or be a contributing factor. I know the pump works and there is power going to it. Fuses are all ok as is the relay. Kill switch isn't inhibiting it and the ignition circuit is fine.
What i have narrowed it down to is the ECM. The ECM is not sending the signal to the fuel relay to purge the fuel pump when the ignition is switched on. I have proved this works by bypassing the ecm when i turn the ignition on.
What could it be that is preventing the ecm from sending the signal to the relay?
any help, input, knowledge or pointers are gratefully received
DJ123 is offline   Reply With Quote
Old 08-08-11, 08:25 PM   #2
Sid Squid
No, I don't lend tools.
Mega Poster
 
Sid Squid's Avatar
 
Join Date: Jul 2003
Location: Skunk Works, Nth London
Posts: 8,680
Default Re: Starting problem-fuel pump not purging

If the pump and relay function, but the pump doesn't pressurise the fuel system, (what I assume you mean by 'purge'*), then have you checked the various lockout switches; sidestand, clutch, neutral? As you have probably previously noticed, there are combinations of sidestand and gear position that inhibit starting and running, if these switches and/or wiring are not working correctly you may find the problem you're experiencing.

*Unless you do mean purge, as in empty, in which case I must be mistaking the fault you're describing.
__________________
If an SV650 has a flat tyre in the forest and no-one is there to blow it up, how long will it be 'til someone posts that the reg/rec is duff and the world will end unless a CBR unit is fitted? A little bit of knowledge = a dangerous thing.

"a deathless anthem of nuclear-strength romantic angst"
Sid Squid is offline   Reply With Quote
Old 08-08-11, 09:50 PM   #3
Stonesie
Guest
 
Posts: n/a
Default Re: Starting problem-fuel pump not purging

Does it say 'CHECK' on the dash? that would point to one of the switches Sid mentioned or the wireing connection to it.
  Reply With Quote
Old 09-08-11, 04:55 PM   #4
DJ123
Member
Mega Poster
 
DJ123's Avatar
 
Join Date: Jul 2011
Location: Somewhere over there
Posts: 3,245
Default Re: Starting problem-fuel pump not purging

Sid, yes. i have checked all the switches that would prevent the pump from pressurising
Stonesie-it does indeed cay check on the dash. my bike won;t boot up the dealer mode either so i can't see the fault code it's throwing up
got it started last night and was over the moon. then soldered up the wires as a more permenant fix and now it won't start again, it won't even turn over. starter motor is refusing to budge-not seized just wont allow me to turn it over.
I have checked the clutch lever switch, TOS, side stand switch, fuses, connections, all wiring.
The monkey that installed the alarm completely buggered it up and wired it in completely wrong thus creating a lot of the problems i am getting. wiring being wrong and changed among other cow boy antics
DJ123 is offline   Reply With Quote
Old 09-08-11, 07:01 PM   #5
muzikill
Member
Mega Poster
 
muzikill's Avatar
 
Join Date: Jul 2005
Location: Dunfermline
Posts: 1,712
Default Re: Starting problem-fuel pump not purging

http://forums.sv650.org/showthread.php?t=169533

you want me to repeat this again bud? lol

The starter should turn, i wouldnt point the fault towards the ECM just yet. The manual has a process for checking the starter motor too. In fact the manual has a easy to read starter circuit layout & a fuel circuit layout.

Are you using the official manual?

You says you got it started last night before you solderered the cables perm. Have checked the opposing ends on the cables you soldered for continuity?
__________________
Learn to maintain your bike, take it apart, rebuild the engine & more (using better bolts ), drop it & fix it again!
K3 Job c.v: Engine:remove/split/rebuild/refit. Replace:Gearbox,Fuel pump,Gaskets. Piston clean,rings. Overhaul:Throttle body,Injectors,Brakes,Forks. Remove/refit:Exhaust,Radiator,Oil cooler,Throttle,Air filter,Tank. Replace: Oil,Coolant,grease,brake hoses & bleed.

Last edited by muzikill; 09-08-11 at 07:03 PM.
muzikill is offline   Reply With Quote
Old 09-08-11, 08:18 PM   #6
DJ123
Member
Mega Poster
 
DJ123's Avatar
 
Join Date: Jul 2011
Location: Somewhere over there
Posts: 3,245
Default Re: Starting problem-fuel pump not purging

currently looking at the electrical diagrams in a Haynes Manual
Yeah it was all checked prior to a temp fix to see if it worked, and then soldered them up
Today there's nothing, check on the dash and thats it. No fuel pump pressurising, no starter motor on the button. Very frustrating
DJ123 is offline   Reply With Quote
Old 09-08-11, 09:28 PM   #7
muzikill
Member
Mega Poster
 
muzikill's Avatar
 
Join Date: Jul 2005
Location: Dunfermline
Posts: 1,712
Default Re: Starting problem-fuel pump not purging

dump the haynes for fault finding and grab yourself the suzuki manual for these sorts of issues it beats haynes hands down.
__________________
Learn to maintain your bike, take it apart, rebuild the engine & more (using better bolts ), drop it & fix it again!
K3 Job c.v: Engine:remove/split/rebuild/refit. Replace:Gearbox,Fuel pump,Gaskets. Piston clean,rings. Overhaul:Throttle body,Injectors,Brakes,Forks. Remove/refit:Exhaust,Radiator,Oil cooler,Throttle,Air filter,Tank. Replace: Oil,Coolant,grease,brake hoses & bleed.
muzikill is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New fuel pump. problem found muzikill SV Talk, Tuning & Tweaking 2 19-05-11 09:32 PM
Fuel pump problem, maybe. mudgutsdunn SV Talk, Tuning & Tweaking 5 11-03-10 11:54 PM
Fuel Pump Problem hindle8907 Bikes - Talk & Issues 2 29-11-09 01:34 PM
Fuel pump cornishrider SV Talk, Tuning & Tweaking 6 02-03-08 07:25 PM
K5> fuel pump phil24_7 Stuff Wanted 11 29-10-07 05:18 AM


All times are GMT. The time now is 06:14 AM.


Powered by vBulletin® - Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.